Centos 7: Mariadb 10.0

I am having problems with mariadb 10 on a vm server. Unable to use mysql databases which I am fully dependent upon!

mysql --version
mysql  Ver 15.1 Distrib 10.0.28-MariaDB, for Linux (x86_64) using readline 5.1
[root@g ~]# service mariadb restart
Redirecting to /bin/systemctl restart  mariadb.service
Failed to restart mariadb.service: Unit not found.

Update: Result of command mysqld --version

mysqld --version
170109 10:38:04 [Warning] 'THREAD_CONCURRENCY' is deprecated and will be removed in a future release.
mysqld  Ver 10.0.28-MariaDB for Linux on x86_64 (MariaDB Server)
170109 10:38:04 [Note] mysqld (mysqld 10.0.28-MariaDB) starting as process 31895 ...

Comments

I am also unable to open or navigate to "Edit Databases" on VM as root. It kind of takes too long or hangs.

Howdy -- CentOS 7 comes with MySQL/MariaDB 5.7, so it sounds like you're using MariaDB from a third party repository there.

Which repository did that come from? And was MariaDB recently updated?

You could always try going into Webmin -> System -> Bootup and Shutdown, and you could try restarting the service from there.

I did not see mariadb in the list; but i did see mysql though.

Problem resolved upon restart of mysql.service

Also, was able to access databases both as root and users, upgrade scripts that depended upon mysql which were not possible before.

Thanks, Andrew, again.

That's great to hear!

Just to check though, to make sure we all understand what's going on here -- what is the output of these two commands:

rpm -qa | grep -i mysql
rpm -qa | grep -i maria
[root@g ~]# rpm -qa | grep -i mysql
php-mysql-5.4.16-42.el7.x86_64
perl-DBD-MySQL-4.023-5.el7.x86_64
rh-php56-php-mysqlnd-5.6.5-7.el7.centos.x86_64
[root@g ~]# rpm -qa | grep -i maria
MariaDB-server-10.0.28-1.el7.centos.x86_64
MariaDB-devel-10.0.28-1.el7.centos.x86_64
MariaDB-shared-10.0.28-1.el7.centos.x86_64
MariaDB-client-10.0.28-1.el7.centos.x86_64
MariaDB-common-10.0.28-1.el7.centos.x86_64