Copied cert to Webmin and Usermin is not detected in 'Manage SSL Certificate'

Hello, I like to get me cert files auto-copied to Postfix, Dovecot, Webmin and Usermin after a Let's encrypt renewal.

First, I created a self-signed cert for my Root domain and pressed all 'Copy to *' buttons under Server Configuration->Manage SSL Certficate->Current Certificate. The status showed 'This SSL certificate is already being used by : Dovecot, Postfix'. The copy to Webmin and Usermin did not get detected.

Then in created a Let's encrypt request. The log showed: [...] Copying certificate and key to /etc/usermin .. .. done Configuring Usermin to use them .. .. done [...]

I assume that the copy to Usermin got detected, but was not displayed in the status of 'Current certificate' tab. The certs to Webmin were NOT copied. If I return to the 'Current certifcate' tab, status shows: 'This SSL certificate is already being used by : Usermin, Dovecot, Postfix'.

Hope for a fix soon. Meanwhile I setup Let's encrypt renewal additionally in the Webmin configuration. Instead of detecting or saving copy operations, wouldn't it be appropriate to have own copy options in the Let's encrypt tab?

Comments

There is a bug in the current Virtualmin release that prevents the copy to Webmin from working.

The work-around is to SSH in as root and run virtualmin install-service-cert --domain yourdomain.com --service webmin

I have this bug on debian 8. Will it be fixed soon?

Yes, we will be releasing 5.06 soon that will include a fix.