unable to start/restart PHP-FPM server

Error:

Jun 13 18:04:37 edge.a1z.us php-fpm[9688]: [13-Jun-2020 18:04:37] ERROR: [pool 159154307421001] unable to set listen address as it's already used i

Or is it related to SUExec https://virtualmin.com/node/69233

Status: 
Active

Comments

This could be due to a port clash in the default FPM pool. Try SSHing in as root and running virtualmin check-config , which will fix that issue.

bislinks's picture
Submitted by bislinks on Sun, 06/14/2020 - 09:43 Pro Licensee

Hello Jamie C,

No, it did not fix it.

[root@edge a1z]# virtualmin check-config Your system has 7.13 GiB of memory, which is at or above the Virtualmin recommended minimum of 256 MiB. BIND DNS server is installed, and the system is configured to use it. Mail server Postfix is installed and configured. Postfix is configured to support per-domain outgoing IP addresses. SuExec cannot be used to run PHP scripts in CGI or FCGId modes : The Suexec command on your system is configured to only run scripts under /var/www, but the Virtualmin virtual server home directory is /home. CGI scripts run as domain owners will not be executed. The following PHP versions are available : 7.2.11 (/bin/php-cgi) The following PHP execution modes are available : fpm The following PHP-FPM versions are available on this system : 7.2.11 (php-fpm) Webalizer is installed. Apache is configured to host SSL websites. MariaDB 10.3.17 is installed and running. ProFTPD is installed. Logrotate is installed. SpamAssassin and Procmail are installed and configured for use. ClamAV is installed and assumed to be running. Plugin AWstats reporting is installed OK. Plugin Administrator's Notes is installed OK. Plugin Analytics Tracking is installed OK. Plugin New Mailbox Signup is installed OK. Plugin SQLite Databases is installed OK. Plugin Additional content styles from OpenWebDesign.org is installed OK. Plugin Additional content styles is installed OK. Plugin Virtualmin Support Links is installed OK. Using network interface eth0 for virtual IPs. IPv6 addresses are available, using interface eth0. Default IPv4 address for virtual servers is 10.128.0.17. Default IPv6 address for virtual servers is fe80::52fa:bcb8:57de:555b. External IP address for DNS records is set to 35.184.118.13, which matches the detected ext ernal address. Both user and group quotas are enabled for home and email directories. All commands needed to create and restore backups are installed. Resource limits are supported and configured correctly. The selected package management and update systems are installed OK. Chroot jails are available on this system The Virtualmin YUM repository is configured correctly Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Use of uninitialized value in split at /usr/libexec/webmin/virtualmin-sqlite/virtual_featur e.pl line 114. Applying web server configuration .. .. done Re-starting DNS server .. .. done OK
[root@edge a1z]# service php-fpm status -l Redirecting to /bin/systemctl status -l php-fpm.service ‚óŹ php-fpm.service - The PHP FastCGI Process Manager Loaded: loaded (/usr/lib/systemd/system/php-fpm.service; disabled; vendor preset: disabled) Active: failed (Result: exit-code) since Sat 2020-06-13 18:04:37 UTC; 20h ago Process: 22616 ExecReload=/bin/kill -USR2 $MAINPID (code=exited, status=0/SUCCESS) Process: 9688 ExecStart=/usr/sbin/php-fpm --nodaemonize (code=exited, status=78) Main PID: 9688 (code=exited, status=78) Jun 13 18:04:37 edge.a1z.us systemd[1]: Starting The PHP FastCGI Process Manager... Jun 13 18:04:37 edge.a1z.us php-fpm[9688]: [13-Jun-2020 18:04:37] ERROR: [pool 159154307421001] unable to set listen address as it'> Jun 13 18:04:37 edge.a1z.us php-fpm[9688]: [13-Jun-2020 18:04:37] ERROR: failed to post process the configuration Jun 13 18:04:37 edge.a1z.us php-fpm[9688]: [13-Jun-2020 18:04:37] ERROR: FPM initialization failed Jun 13 18:04:37 edge.a1z.us systemd[1]: php-fpm.service: Main process exited, code=exited, status=78/CONFIG Jun 13 18:04:37 edge.a1z.us systemd[1]: php-fpm.service: Failed with result 'exit-code'. Jun 13 18:04:37 edge.a1z.us systemd[1]: Failed to start The PHP FastCGI Process Manager. [root@edge a1z]# [root@edge a1z]#
bislinks's picture
Submitted by bislinks on Sun, 06/14/2020 - 10:11 Pro Licensee

Got it.

two users had same port assigned to them: 8013.

Dono how that did happen.

bislinks's picture
Submitted by bislinks on Sun, 06/14/2020 - 10:13 Pro Licensee


[root@edge ~]# systemctl start php-fpm [root@edge ~]#

Did two users have the same port assigned in the same FPM version?

bislinks's picture
Submitted by bislinks on Mon, 06/15/2020 - 06:53 Pro Licensee

On this server, I only have one version of PHP installed: 7.2.11.

I do not see a version specified in /etc/php-fpm.d/*.conf files.

[root@edge ~]# cat /etc/php-fpm.d/15894825145815.conf . . . listen = localhost:8000 pm = dynamic pm.max_children = 9999 pm.start_servers = 1 pm.min_spare_servers = 1 pm.max_spare_servers = 5 . . . php_value[max_execution_time] = 30 [root@edge ~]#

Not sure if that is the answer you were expecting..